Microphone issues

Following download, tried to test the system this evening, the leader on a Mac and the others on Lap Tops… We had the following issues:
1)Microphone volume was a problem for two of us, and we checked in settings. Our Test result were below 5 with full slider volume. Two of us were using plug in ear speakers from mobile phones.
2)We struggled to hear each other with feedback conversation some time later. There was a lot of crackling
3) The Leader suggested I go to help and run the test. It gave the following results.
---- 11----
How are you connected?: Wire
Is the connection blocked by a firewall?: No!
How long to reach Google.com?: Unknown
Can we reach the flock server?: Yes!
How long to connect to your router?: Unknown
Download speed: Unknown
Upload speed: Unknown
Audio interface buffer size equals 128?: 144 Samples
Audio interface sample rate equals 44100?: 48000 Hz
Computing next prime number: 1.02 Seconds
Computer Memory free: Unknown
---- 11----
The leader told this was concerning. I am using the correct wired connection to my Router and have turned off WIFI.
Do I have something fundamentally wrong?

Hi Tim and thanks for trying out Flock.

Microphone volume is usually one of a few possibilities

  • increase mic volume in Windows settings (sometimes you need to use the Boost setting)
  • ensure that Windows does not have background noise cancellation enabled on the mic. Also in Windows sound settings
  • it’s possible that you’ve got background noise enabled in Flock. Go to Settings and put the sliders for both settings (Threshold and Ratio) to the far left.

More info here:
Troubleshooting doc: https://community.flock.digital/t/troubleshooting-guide/85#heading–mic-setup
How to set your audio levels: Set your mic audio level correctly - #2

Your test results look fine. The only doubt is the setting at 48000 Hz. If you hear audio distortion then make sure that in Windows sound settings for both mic and headset advanced settings they are both set to 4800 Hz. Or alternatively switch Flock and Windows over to 44,100 Hz. The Sample rate settings in Windows and Flock need to match up.


Thank you, I will work on your suggestions

Hi Paul. Feedback for you. I am a singer. and have Windows. We had a session yesterday to see how if worked with a few of the choir.
I kept being thrown out just by pressing a button in Flock or just for no reason.
It came in using Assio and gave me no option to change to my USB head phones. I went to settings Audio and chose Windows Audio and it picked up my USB headphones. I set my buffer size to lowest there 144 and left the Sample rate at 48,000. It worked well with some of the people. But from time to time I was thrown out as I moved around the setting to help other people.
I came out of Flock and set my Lap Top to 44,100. Flock did not like this at all and kept throwing me out. So I reset Windows to 48,000, rest Flock to 144 (which kept changing to 512 every time I was thrown out) and was back with a workable system. Great.
We went back in later, I was again thrown out a couple of times and I had to reset to Windows Audio and Buffer size to 144 every time I was thrown out.

When you say “thrown out” is that disconnected from a session or did the entire application close (i.e. crash)?

If the former, then it’s a problem we’ve been having this week with our server. We’re reasonably confident that is has now been resolved.

We also will soon be releasing an updated version of Flock which solves the problem you’re mentioning about reverting to 512 samples.

Hope that helps

@paulr I’ve encountered a bunch of Mac folks )using mostly Apple standard headphones) whose setup is creating a slight echo from my voice. I’ve confirmed that sound isn’t coming through the speakers, and it’s not that runaway train feedback thing. Any thoughts? Thanks!

It might be related to the model of Mac. Newer Mac have some restrictions which the older Macs don’t have. @Sander what do you think?

Thanks! One user was definitely on an older (2017-18) model…