Tried twice - I'm leader and I am windows user

Tried yesterday with one other singer who is a mac user but had no ethernet cable. There was a lot of what sounded like interference/static & hissing on the line at both ends which I did not manage to sort out.

Tried again today with a few more. 1 mac user with wired internet and headphones which was all quite successful but she could still hear the interference; one couple using windows but everything wired - a bit more delay and they need to investigate their microphone settings as they were always quieter even when I adjusted their volume. They tried to run two computers (all with wired connection etc) but one really didn’t work well and they couldn’t hear the audio. A third person tried to connect but kept being unable to hear audio and being removed from the room (I’ve sent her the troubleshooting guide)

There seemed to be accumulated delays. We tried singing a bit of locus iste with a pre-recorded track with click and by about bar 8 things were always a little behind. As leader can I sing with the track I hear here (which was being played through a separate device not my computer) or am I better to not sing at all?

Still very exciting though and I will keep trying!

Thanks for persevering!

A few comments:

  • Mac user with no ethernet cable. Flock doesn’t work properly on WiFi. You should mute that singer until they have a wired connection.
  • Mac user wired connection. Glad to hear that’s working. She is hearing interference from the other singers who are not setup correctly.
  • Windows couple with delays and too quiet. They should try the Health Check feature and then for every red or orange light, there is a link to a short help article here on the forum. You can also send them these links:
    Troubleshooting - delays
    Troubleshooting - Mic setup
    Set mic audio level correctly

On accumulated delays, @edaldcroft may have some tips for you. From my side

  • knowledge / confidence of the song makes a big difference… part of the accumulated delay comes from micro-waiting for other singers. And then this builds up.
  • pre-recorded track helps a lot, especially with click to keep singers together. would be better if you’re able to play through your computer or better if you can play through your audio interface
  • as the group size increases, the “hear my section louder” feature make a big difference. singers listen for voices in their section to keep together
  • yes you can sing along and that also helps keep singers together. The leader’s volume is louder than everyone else so it’s a bit of experimenting, either singing the whole song or just parts

All very helpful & quick - thanks. My non-ethernet using singer was muted! I currently do not have an external audio interface and am using asio4all. I am happy to invest in an external audio interface - will it make a big difference?

Hmm it could be that you’re not setup correctly on Asio4all which would explain why putting the Mac user on mute didn’t help.

Can you do a health check and then copy paste the results here. And also open up asio4all control panel when your headphones are connected and take a screen shot and post it

The audio interface is generally a useful piece of equipment for choir directors. I’ll let @edaldcroft comment on his experience. It also makes the setup of flock on windows much easier. The key thing is that the audio interface should support 44.1kHz and should come with its own ASIO driver (not asio4all).

Health Check results from tonight:

---- v 1.3.9----

Wired internet connection?: Wire

Can we reach the flock server?: Yes!

Central server can reach flock app?: Yes!

How long to connect to your router?: 4.67ms

Download speed: 80.29 Mbit/s

Upload speed: 31.03 Mbit/s

Internet Ping: 9.45 Ms

Audio buffer size equals 128?: 128 Samples

Audio sample rate equals 44100?: 44100 Hz

Computing challenge speed test: 1.01 Seconds

---- 10----

I then made sure all wifi/other ethernet using things were off and tried again and time to connect to router still very similar (i.e. much slower than I expected).

Screenshot attached of asio4all/flock . If I try to not have the Q8 audio OUT clicked it also won’t recognise the Realtek output which is what I have to use

That is quite slow to reach your router. Normally it should be less than 1ms. As long as you don’t notice delays on Flock I suppose you can ignore it. If you wanted to explore this further, you could try to identify whether it’s a problem with your computer, other devices on your home network or your router. To do that, disconnect all devices (computers, phones, tablets, printers, smartTV, game consoles, etc) from your network. Then try the health check from your computer again. Then disconnect your computer and try the Health check in Flock from another computer. If both still give a high ping to the router then it could be that your router is older, slow or misconfigured and may be worth a call to your internet provider. If your computer gives the high ping and another computer does not then could be a problem with the network card on your computer.

The screenshot looks good. Two additional things to check

  1. In the ASIO4ALL screen, when you click on Realtek, it should also be setup with ASIO Buffer size of 128 samples.
  2. In Windows Control Panel → Sound settings, select your mic go to advanced properties and make sure that the Sample rate is 44,100Hz. Then do the same for the headphones. (i.e. so that it matches up with the 44,100 Hz you’ve got in Flock.

I did try switching off all other devices on the network yesterday and it didn’t make a difference to the time to reach the router

Asio4all all bits set to 128
Microphone (I am using zoom q8 as usb mike) 44100
headphones 44100 is not an option - any other ideas? If I get an external audio interface I will need to get a different microphone

Sorry for asking so many questions but I really want to get this to work! I have a usb-headphone jack converter so I tried that (as I wondered if some of the crackling was anything to do with my headphone socket). Going via control panel and sounds I could change that to 41100 but when I tried to use flock although this new usb audio appeared in asio4all and I selected it, flock did not then recognise anything (microphone or headphones). Any ideas? When I took this out and went back to using headphone jack it worked again

You could also try rebooting your router. Switch it off and then after a minute, restart it. If that doesn’t work you could call your internet provider and they might be able to help.

Do you have another set of headphones to test that can do 44,100? Even if they’re really cheap headphones, it may point you to solving the problem.

I may have done it…no one to try it out with until Sunday now though. I’ve been using a ZoomQ8 as a USB microphone so I’m plugging the headphones in there and they seem to have the correct rate of 44100